#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\/\*(?:.|\n)*?GNU General Public License(?:.|\n)*?\*\/|\"use strict";"
Local $sString = "/* " & @CRLF & _
" * This file is part of OverPy (https://github.com/Zezombye/overpy)." & @CRLF & _
" * Copyright (c) 2019 Zezombye." & @CRLF & _
" * " & @CRLF & _
" * This program is free software: you can redistribute it and/or modify " & @CRLF & _
" * it under the terms of the GNU General Public License as published by " & @CRLF & _
" * the Free Software Foundation, version 3." & @CRLF & _
" *" & @CRLF & _
" * This program is distributed in the hope that it will be useful, but " & @CRLF & _
" * WITHOUT ANY WARRANTY; without even the implied warranty of " & @CRLF & _
" * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU " & @CRLF & _
" * General Public License for more details." & @CRLF & _
" *" & @CRLF & _
" * You should have received a copy of the GNU General Public License " & @CRLF & _
" * along with this program. If not, see <http://www.gnu.org/licenses/>." & @CRLF & _
" */" & @CRLF & _
"" & @CRLF & _
""use strict";" & @CRLF & _
"" & @CRLF & _
"astParsingFunctions["_&addToScore"] = function(content) {" & @CRLF & _
"" & @CRLF & _
" if (enableOptimization) {" & @CRLF & _
" if (content.args[0].name === "__number__" && content.args[0].args[0].numValue === 0) {" & @CRLF & _
" return getAstForUselessInstruction();" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
" " & @CRLF & _
" return content;" & @CRLF & _
"}"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)