re = /^(?=.{6,})(?=.*[a-z])(?=.*[A-Z])(?=.*[\()@#$£%^!&*+=-_]).*$/m
str = 'aaA!udqqq1
Pw12a)
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end