$re = '/^(?=.{6,})(?=.*[a-z])(?=.*[A-Z])(?=.*[\()@#$£%^!&*+=-_]).*$/m';
$str = 'aaA!udqqq1
Pw12a)
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);