re = /(RSTART_(?=(([A-Z0-9]{6}[0-9]))))|(NO_SIGNAL)/m
str = ' {RSTART_IDT1S03, RSTART_IDT1S03},
{RSTART_IDT1S03, NO_SIGNAL},
{NO_SIGNAL, RSTART_IDT1S03},
{NO_SIGNAL, NO_SIGNAL},
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end