const regex = new RegExp('(RSTART_(?=(([A-Z0-9]{6}[0-9]))))|(NO_SIGNAL)', 'mg')
const str = ` {RSTART_IDT1S03, RSTART_IDT1S03},
{RSTART_IDT1S03, NO_SIGNAL},
{NO_SIGNAL, RSTART_IDT1S03},
{NO_SIGNAL, NO_SIGNAL},
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}