const regex = new RegExp('\\b(?!(?:JR|SR|II|III|ESQ|PHD|MD)\\b)\\w+\\b(?=\\W*\\w+\\b)', 'gmi')
const str = `De la cruz
de la cruz jr
santiago
smith
smith johnson
smith johnson II
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}