#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)\b(?!(?:JR|SR|II|III|ESQ|PHD|MD)\b)\w+\b(?=\W*\w+\b)"
Local $sString = "De la cruz" & @CRLF & _
"de la cruz jr" & @CRLF & _
"santiago" & @CRLF & _
"smith" & @CRLF & _
"smith johnson" & @CRLF & _
"smith johnson II" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")