import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "%%([\\S\\s]*?)%%";
final String string = "Dear {#var#},\n"
+ "Please find your Booking Confirmation details\n"
+ "Transcation ID : %%|TranscationID^{\"inputtype\" : \"text\", \"maxlength\" : \"45\"}%%\n"
+ "Truck No : %%|TruckNo^{\"inputtype\" : \"text\", \"maxlength\" : \"15\"}%%\n"
+ "From : %%|FromLoc^{\"inputtype\" : \"text\", \"maxlength\" : \"30\"}%%\n"
+ "To : %%|ToLoc^{\"inputtype\" : \"text\", \"maxlength\" : \"30\"}%%\n"
+ "Rent(INR) : %%|Fright^{\"inputtype\" : \"text\", \"maxlength\" : \"8\"}%%\n"
+ "Advance(INR) : %%|AdvanceAmt^{\"inputtype\" : \"text\", \"maxlength\" : \"8\"}%%\n"
+ "Loading Address : %%|LoadingAddre^{\"inputtype\" : \"text\", \"maxlength\" : \"100\"}%%";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}