using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"%%([\S\s]*?)%%";
string input = @"Dear {#var#},
Please find your Booking Confirmation details
Transcation ID : %%|TranscationID^{""inputtype"" : ""text"", ""maxlength"" : ""45""}%%
Truck No : %%|TruckNo^{""inputtype"" : ""text"", ""maxlength"" : ""15""}%%
From : %%|FromLoc^{""inputtype"" : ""text"", ""maxlength"" : ""30""}%%
To : %%|ToLoc^{""inputtype"" : ""text"", ""maxlength"" : ""30""}%%
Rent(INR) : %%|Fright^{""inputtype"" : ""text"", ""maxlength"" : ""8""}%%
Advance(INR) : %%|AdvanceAmt^{""inputtype"" : ""text"", ""maxlength"" : ""8""}%%
Loading Address : %%|LoadingAddre^{""inputtype"" : ""text"", ""maxlength"" : ""100""}%%";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}