$re = '/(<a .*?)(href="|\')(http:\/\/oceanexplorer.noaa.gov\/redirectimage.php\?url=|\/redirectimage.php\?url=|\/redirectimage.php\?url=)([.\s\S]*?)(<\/a>)/';
$str = 'g_ImageTable[g_imax++] = new Array ("gallery/600/1.jpg", "The inflatable baby pool used for the phytoplankton experiment. <em>Image courtesy of 2009 RUSALCA Expedition, RAS-NOAA.</em><br /><br /><!--strong><a href=\'/redirectimage.php?url=http://oceanexplorer.noaa.gov/explorations/09bioluminescence/background/hires/bamboo_coral_hires.jpg\' title=\'Download high-resolution image\' target=\'window_name\'>Download high-resolution image (jpg, 547 KB)</a></strong-->");
';
$subst = "\1\2\4 <img src=\"/siteart/newwindow.png\" width=\"10\" height=\"11\" alt=\"exit icon\" title=\"exit icon\"/>\5";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;