// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)<AUDT:INFO>.(?<date>\d+.\d+.\d+) (?:\d+:\d+:\d+) (?:\d+.\d+.\d+.\d+) (?:.*(?<subject>Failed 'Active Directory' login attempt)(?:.\w+.\w+)(?<impacteduser>.*?'\W))\w+.\w+.\w+.\w+.'(?<sip>.\d+.\d+.\d+.\d+)'").unwrap();
let string = "08 20 2020 11:18:08 10.72.1.17 <AUDT:INFO> 2020-08-20 11:17:12 10.72.1.17 Passwordstate: Failed 'Active Directory' login attempt for UserID 'fakedoamin\\FakeUser' from the IP Address '10.72.1.231'. Possible incorrect Username or Password, or this could also be caused by restricted Logon Hours in Active Directory. Client IP Address = 10.72.1.231
08 21 2020 08:32:25 10.72.1.17 <AUDT:INFO> 2020-08-21 08:31:58 10.72.1.17 Passwordstate: Successful Active Directory login for UserID 'fakedoamin\\FakeUser' from the IP Address '10.72.1.17'. Client IP Address = 10.14.1.93
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}