using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<AUDT:INFO>.(?<date>\d+.\d+.\d+) (?:\d+:\d+:\d+) (?:\d+.\d+.\d+.\d+) (?:.*(?<subject>Failed 'Active Directory' login attempt)(?:.\w+.\w+)(?<impacteduser>.*?'\W))\w+.\w+.\w+.\w+.'(?<sip>.\d+.\d+.\d+.\d+)'";
string input = @"08 20 2020 11:18:08 10.72.1.17 <AUDT:INFO> 2020-08-20 11:17:12 10.72.1.17 Passwordstate: Failed 'Active Directory' login attempt for UserID 'fakedoamin\FakeUser' from the IP Address '10.72.1.231'. Possible incorrect Username or Password, or this could also be caused by restricted Logon Hours in Active Directory. Client IP Address = 10.72.1.231
08 21 2020 08:32:25 10.72.1.17 <AUDT:INFO> 2020-08-21 08:31:58 10.72.1.17 Passwordstate: Successful Active Directory login for UserID 'fakedoamin\FakeUser' from the IP Address '10.72.1.17'. Client IP Address = 10.14.1.93
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}