# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"num_externe\s*=(?'num_externe'.*?)\s*xfi_cd.*ins_numins\s*=(?'ins_numins'.*?)\s*apt_nom\s*=(?'apt_nom'.*?)\s*apt_type\s*=(?'apt_type'.*?)\s*apt_telephone\s*=(?'apt_telephone'.*?)\s*tsy_cd\s*=(?'tsy_cd'.*?)\s*qsy_cd\s*=(?'qsy_cd'.*?)\s*commentaire_externe\s*=(?'commentaire_externe'.*?)\s*apt_localisation\s*=(?'apt_localisation'.*?)\s*urg_cd"
test_str = (" \n"
" \n"
" num_externe=1607770.01 xfi_cd=E ins_numins=5490201001 apt_nom=AMMAR/Fathia apt_type=CLI\n"
"apt_telephone=0156658495 tsy_cd=3116 qsy_cd=1 commentaire_externe=B490 - RETIRER LE NÉON QUI SE TROUVE AU DESSUS DU BUREAU SVP MERCI apt_localisation=B463////Courbevoie urg_cd= dtheure_limite= \n"
" \n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.