const regex = /num_externe\s*=(?'num_externe'.*?)\s*xfi_cd.*ins_numins\s*=(?'ins_numins'.*?)\s*apt_nom\s*=(?'apt_nom'.*?)\s*apt_type\s*=(?'apt_type'.*?)\s*apt_telephone\s*=(?'apt_telephone'.*?)\s*tsy_cd\s*=(?'tsy_cd'.*?)\s*qsy_cd\s*=(?'qsy_cd'.*?)\s*commentaire_externe\s*=(?'commentaire_externe'.*?)\s*apt_localisation\s*=(?'apt_localisation'.*?)\s*urg_cd/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('num_externe\\s*=(?\'num_externe\'.*?)\\s*xfi_cd.*ins_numins\\s*=(?\'ins_numins\'.*?)\\s*apt_nom\\s*=(?\'apt_nom\'.*?)\\s*apt_type\\s*=(?\'apt_type\'.*?)\\s*apt_telephone\\s*=(?\'apt_telephone\'.*?)\\s*tsy_cd\\s*=(?\'tsy_cd\'.*?)\\s*qsy_cd\\s*=(?\'qsy_cd\'.*?)\\s*commentaire_externe\\s*=(?\'commentaire_externe\'.*?)\\s*apt_localisation\\s*=(?\'apt_localisation\'.*?)\\s*urg_cd', 'gm')
const str = `
num_externe=1607770.01 xfi_cd=E ins_numins=5490201001 apt_nom=AMMAR/Fathia apt_type=CLI
apt_telephone=0156658495 tsy_cd=3116 qsy_cd=1 commentaire_externe=B490 - RETIRER LE NÉON QUI SE TROUVE AU DESSUS DU BUREAU SVP MERCI apt_localisation=B463////Courbevoie urg_cd= dtheure_limite=
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}