// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\W*file\W*:\s*\W+(.*)\W+,").unwrap();
let string = "file: \"http://www.sharevids.net/user/chenna/justicebao08/bao01w.mp4\",
file: 'http://www.sharevids.net/user/chenna/justicebao08/bao01w.mp4',
\"file\": \"http://www.sharevids.net/user/chenna/justicebao08/bao01w.mp4\",
'file': \"http://www.sharevids.net/user/chenna/justicebao08/bao01w.mp4\",
'file': 'http://www.sharevids.net/user/chenna/justicebao08/bao01w.mp4',";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}