$re = '/\W*file\W*:\s*\W+(.*)\W+,/';
$str = 'file: "http://www.sharevids.net/user/chenna/justicebao08/bao01w.mp4",
file: \'http://www.sharevids.net/user/chenna/justicebao08/bao01w.mp4\',
"file": "http://www.sharevids.net/user/chenna/justicebao08/bao01w.mp4",
\'file\': "http://www.sharevids.net/user/chenna/justicebao08/bao01w.mp4",
\'file\': \'http://www.sharevids.net/user/chenna/justicebao08/bao01w.mp4\',';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);