import Foundation
let pattern = #"(?i)(jsc)=.*?(;\s?|\s?) "#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"JSC=wnCuqQ5vyFKcoeShsxZ7G2s8Bej4GCMI1YXd4PXf0fxPWLkrGCXnXr7EQK2eaaFXg_NwYDDdxEzSc2gkGZYZDhli4MzgNU2cCIW9KQ94BxbagB_Jq3ZCjp2BKpX3HCoTWvyMdSJaNGU40BjmYkybqGtXsiUXFJhFkb0KR_ykc_dEbcLMT2qIefBo9EZeMpXI2oSFl9JAi_lubjsTwSlo3kCGnf9qcfgYF_3LVJYpdsGkcNkkOaL4CGpHSZfCHtqQKzg1s3-6mfxtF-0RGD5nSI2AU6aNMgseEng_9fkGZ9_DZPnwo_8FRAQFoyapTsPy; __cfduid=d11f3a496a9bca3324d5a325ab57de95b1590591641; _csrf=dDJnl-L9LdJWLn2vcrlKDRau"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)