// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?i)(jsc)=.*?(;\s?|\s?) ").unwrap();
let string = "JSC=wnCuqQ5vyFKcoeShsxZ7G2s8Bej4GCMI1YXd4PXf0fxPWLkrGCXnXr7EQK2eaaFXg_NwYDDdxEzSc2gkGZYZDhli4MzgNU2cCIW9KQ94BxbagB_Jq3ZCjp2BKpX3HCoTWvyMdSJaNGU40BjmYkybqGtXsiUXFJhFkb0KR_ykc_dEbcLMT2qIefBo9EZeMpXI2oSFl9JAi_lubjsTwSlo3kCGnf9qcfgYF_3LVJYpdsGkcNkkOaL4CGpHSZfCHtqQKzg1s3-6mfxtF-0RGD5nSI2AU6aNMgseEng_9fkGZ9_DZPnwo_8FRAQFoyapTsPy; __cfduid=d11f3a496a9bca3324d5a325ab57de95b1590591641; _csrf=dDJnl-L9LdJWLn2vcrlKDRau";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}