$re = '/(^[ \t]*)Global([^\n\;\/]*);?/m';
$str = 'Global Base:TList=New TList; // База загруженных спрайтив. Чтобы не грузить одно и то же
//цвета ключевых пикселей, испульзуемых в поиске
Global PxAlpha = -GenRgb(0, 0, 0, 0)
Global PxRed = -GenRgb(0, 1, 0, 0) // 65536
Global PxBlack = -GenRgb(1, 0, 0, 0); // 16777216
Global => public static';
$subst = "$1public static$2;";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;