using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^[ \t]*)Global([^\n\;\/]*);?";
string substitution = @"$1public static$2;";
string input = @"Global Base:TList=New TList; // База загруженных спрайтив. Чтобы не грузить одно и то же
//цвета ключевых пикселей, испульзуемых в поиске
Global PxAlpha = -GenRgb(0, 0, 0, 0)
Global PxRed = -GenRgb(0, 1, 0, 0) // 65536
Global PxBlack = -GenRgb(1, 0, 0, 0); // 16777216
Global => public static";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}