$re = '/^([1-9]{1}\d{1,11}|0)(\.\d{1,2})?$/';
$str = '0.11';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);