package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([1-9]{1}\d{1,11}|0)(\.\d{1,2})?$`)
var str = `0.11`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}