import Foundation
let pattern = #"(((^|\n*).{1,42}?)(\n))|(\n*.{1,42})( |\n|$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = #"""
Below, we present an introduction to advanced regular expressions, with eight commonly used concepts and examples.
Each example outlines a simple way to match patterns in complex strings.
If you do not yet have experience with basic regular expressions, have a look at this article to get started. The syntax used here matches PHP regular expressions.Regular expressions (or regex) are a powerful way to traverse large strings in order to find information. They rely on underlying patterns in a string’s structure to work their magic. Unfortunately, simple regular expressions are unable to cope with complex patterns and symbols. To deal with this dilemma, you can use advanced regular expressions.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\2\5\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)