const regex = /(((^|\n*).{1,42}?)(\n))|(\n*.{1,42})( |\n|$)/gsm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(((^|\\n*).{1,42}?)(\\n))|(\\n*.{1,42})( |\\n|$)', 'gsm')
const str = `Below, we present an introduction to advanced regular expressions, with eight commonly used concepts and examples.
Each example outlines a simple way to match patterns in complex strings.
If you do not yet have experience with basic regular expressions, have a look at this article to get started. The syntax used here matches PHP regular expressions.Regular expressions (or regex) are a powerful way to traverse large strings in order to find information. They rely on underlying patterns in a string’s structure to work their magic. Unfortunately, simple regular expressions are unable to cope with complex patterns and symbols. To deal with this dilemma, you can use advanced regular expressions.`;
const subst = `\2\5\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);