const regex = /^(1\s?)?((\([0-9]{3}\))|[0-9]{3})[\s\-]?[\0-9]{3}[\s\-]?[0-9]{4}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(1\\s?)?((\\([0-9]{3}\\))|[0-9]{3})[\\s\\-]?[\\0-9]{3}[\\s\\-]?[0-9]{4}$', 'gm')
const str = `872-456-4532
(872) 456-4532
8724564532
1 872-456-4532
1 (872) 456-4532`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);