#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(1\s?)?((\([0-9]{3}\))|[0-9]{3})[\s\-]?[\0-9]{3}[\s\-]?[0-9]{4}$"
Local $sString = "872-456-4532" & @CRLF & _
"(872) 456-4532" & @CRLF & _
"8724564532" & @CRLF & _
"1 872-456-4532" & @CRLF & _
"1 (872) 456-4532"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)