$re = '/(\d{4,5})\s(.*)/m';
$str = '35460 Bad Soden am Taunus
D-76275 Musterstadt
6275 Musterstadt 2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);