package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d{4,5})\s(.*)`)
var str = `35460 Bad Soden am Taunus
D-76275 Musterstadt
6275 Musterstadt 2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}