$re = '/^http:\/\/pre.m[1|2]?.lacaixa.es:80\/SPD\/docs\/general\/APPatencio(Lite)?_(es|ca|en|eu|gl)\.html/m';
$str = 'http://pre.m2.lacaixa.es:80/SPD/docs/general/APPatencio_es.html
Amb targeta:
http://pre.m2.lacaixa.es:80/SPD/docs/general/APPatencio_es.html
http://pre.m2.lacaixa.es:80/SPD/docs/general/APPatencio_ca.html
http://pre.m2.lacaixa.es:80/SPD/docs/general/APPatencio_en.html
http://pre.m2.lacaixa.es:80/SPD/docs/general/APPatencio_eu.html
http://pre.m2.lacaixa.es:80/SPD/docs/general/APPatencio_gl.html
Sense targeta:
http://pre.m2.lacaixa.es:80/SPD/docs/general/APPatencioLite_es.html
http://pre.m2.lacaixa.es:80/SPD/docs/general/APPatencioLite_ca.html
http://pre.m2.lacaixa.es:80/SPD/docs/general/APPatencioLite_en.html
http://pre.m2.lacaixa.es:80/SPD/docs/general/APPatencioLite_eu.html
http://pre.m2.lacaixa.es:80/SPD/docs/general/APPatencioLite_gl.html
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);