#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^http:\/\/pre.m[1|2]?.lacaixa.es:80\/SPD\/docs\/general\/APPatencio(Lite)?_(es|ca|en|eu|gl)\.html"
Local $sString = "http://pre.m2.lacaixa.es:80/SPD/docs/general/APPatencio_es.html" & @CRLF & _
"Amb targeta: " & @CRLF & _
"http://pre.m2.lacaixa.es:80/SPD/docs/general/APPatencio_es.html" & @CRLF & _
"http://pre.m2.lacaixa.es:80/SPD/docs/general/APPatencio_ca.html" & @CRLF & _
"http://pre.m2.lacaixa.es:80/SPD/docs/general/APPatencio_en.html" & @CRLF & _
"http://pre.m2.lacaixa.es:80/SPD/docs/general/APPatencio_eu.html" & @CRLF & _
"http://pre.m2.lacaixa.es:80/SPD/docs/general/APPatencio_gl.html " & @CRLF & _
" " & @CRLF & _
"Sense targeta: " & @CRLF & _
"http://pre.m2.lacaixa.es:80/SPD/docs/general/APPatencioLite_es.html" & @CRLF & _
"http://pre.m2.lacaixa.es:80/SPD/docs/general/APPatencioLite_ca.html" & @CRLF & _
"http://pre.m2.lacaixa.es:80/SPD/docs/general/APPatencioLite_en.html" & @CRLF & _
"http://pre.m2.lacaixa.es:80/SPD/docs/general/APPatencioLite_eu.html" & @CRLF & _
"http://pre.m2.lacaixa.es:80/SPD/docs/general/APPatencioLite_gl.html" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")