import Foundation
let pattern = #"(Gen|Gn|Ex|Lev|Lv|Nm|Dt|Jos|Jue|1°Sam|2°Sam|1°Rey|2°Rey|Job|Sal|Prov|Cant|Is|Jer|Ez|Dan|Dn|Os|Miq|Sof|Zac|Mal|Mt|Mc|Lc|Jn|Hch|Rm|Rom|1°Co|1°Cor|Cor|2°Co|2°Cor|Ga|Gal|Ef|Flp|Col|1°Tes|2°Tes|1°Tim|2°Tim|Tito|Heb|Sant|Stgo|1°Ped|2°Ped|1°Jn|Ap|Tob|Sab|Eclo|Sir|1°Mac|2°Mac|Isaías|Jeremías|Zacarías|Hechos|Mateo|Salmo|Judit) ([0-9]{1,3})(?:,(\d{1,3}))?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Ex 32,1-14
Rom 1,18ss, (DH 3004
Rom 1,18-2
Ex 32,1-1
Sal 14,1
Heb 11,1: “La fe es
Heb 1,1ss
Ef 1,9
1°Cor 2,6-10
Heb 11,1:
Heb 12,2, se exalta a
1°Cor 15,3-5 y Hch 2,22-24.
Mt 25,40; Stgo 2,14-26; 1°Jn 4,8.20
Gen 31,5, Gen 31,42, etc.
Gen 45,8. o SEB
Ex 20,5-6; Ex 34,6
Ex 22
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)