#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(Gen|Gn|Ex|Lev|Lv|Nm|Dt|Jos|Jue|1°Sam|2°Sam|1°Rey|2°Rey|Job|Sal|Prov|Cant|Is|Jer|Ez|Dan|Dn|Os|Miq|Sof|Zac|Mal|Mt|Mc|Lc|Jn|Hch|Rm|Rom|1°Co|1°Cor|Cor|2°Co|2°Cor|Ga|Gal|Ef|Flp|Col|1°Tes|2°Tes|1°Tim|2°Tim|Tito|Heb|Sant|Stgo|1°Ped|2°Ped|1°Jn|Ap|Tob|Sab|Eclo|Sir|1°Mac|2°Mac|Isaías|Jeremías|Zacarías|Hechos|Mateo|Salmo|Judit) ([0-9]{1,3})(?:,(\d{1,3}))?"
Local $sString = "Ex 32,1-14" & @CRLF & _
"Rom 1,18ss, (DH 3004" & @CRLF & _
"Rom 1,18-2" & @CRLF & _
"Ex 32,1-1" & @CRLF & _
"Sal 14,1" & @CRLF & _
"Heb 11,1: “La fe es " & @CRLF & _
"Heb 1,1ss" & @CRLF & _
"Ef 1,9" & @CRLF & _
"1°Cor 2,6-10" & @CRLF & _
"Heb 11,1: " & @CRLF & _
"Heb 12,2, se exalta a " & @CRLF & _
"1°Cor 15,3-5 y Hch 2,22-24. " & @CRLF & _
"Mt 25,40; Stgo 2,14-26; 1°Jn 4,8.20" & @CRLF & _
" Gen 31,5, Gen 31,42, etc. " & @CRLF & _
"Gen 45,8. o SEB" & @CRLF & _
" Ex 20,5-6; Ex 34,6" & @CRLF & _
"Ex 22" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")