const regex = /(?:(?:ftp|https?):\/\/|mailto:)(?:\w+(?::\w+)?@)?(?:(?:[a-zA-Z\-][\w+-\.]*)|(?:[\d\.]+))(?:\/\w[\w\.\/%]+)?(?:\?(?:\w+=\w+(?:&\w+=\w+)+))?(?:#\w+)?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(?:ftp|https?):\\\/\\\/|mailto:)(?:\\w+(?::\\w+)?@)?(?:(?:[a-zA-Z\\-][\\w+-\\.]*)|(?:[\\d\\.]+))(?:\\\/\\w[\\w\\.\\\/%]+)?(?:\\?(?:\\w+=\\w+(?:&\\w+=\\w+)+))?(?:#\\w+)?', 'g')
const str = `ftp://sub.domain
mailto:example@example.com
http://127.0.0.1/index.htm
https://user:password@s--ub.do_main.com/path%20/to/whatever.html?key1=value1&key2=value2#fragment`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}