package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:(?:ftp|https?):\/\/|mailto:)(?:\w+(?::\w+)?@)?(?:(?:[a-zA-Z\-][\w+-\.]*)|(?:[\d\.]+))(?:\/\w[\w\.\/%]+)?(?:\?(?:\w+=\w+(?:&\w+=\w+)+))?(?:#\w+)?`)
var str = `ftp://sub.domain
mailto:example@example.com
http://127.0.0.1/index.htm
https://user:password@s--ub.do_main.com/path%20/to/whatever.html?key1=value1&key2=value2#fragment`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}