# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\[(?<headingtag>\w+)\]|(?<tag>\w+)\s+=\s+(?<code>\W+$)|(\k<tag>\w+)\s+=\s+(\k<code>.*)"
test_str = ("[abilities]\n"
"UnknownDescTech0 = このアビリティの効果は不明。\n"
"UnknownDescFun0 = 説明なし。\n"
"UnknownName = ???のアビリティ。\n\n"
"OneHitDeathName = ワンパンヒーローのバッジ\n"
"OneHitDeathDesc0 = 一発で死にます。上級者向け!\n\n"
"SuckInOrbsName = 磁石のバッジ\n"
"SuckInOrbsFun0 = アイテムに手が届かない? これでもう安心。\n"
"SuckInOrbsTech0 = 自動で近くのアイテムを引き寄せます!\n\n\n"
"[abilities_test]\n"
"UnknownName = ??? Ability\n"
"UnknownDescFun0 = No description.\n"
"UnknownDescTech0 = This ability does not seem to have any purpose.\n\n"
"OneHitDeathName = 1-Hit Hero Badge\n"
"OneHitDeathDesc0 = You die in one hit. Only for the brave!\n\n"
"SuckInOrbsName = Item Magnet Badge\n"
"SuckInOrbsFun0 = Item just out of reach? No longer a problem!\n"
"SuckInOrbsTech0 = Automatically attract nearby collectibles!")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.