#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\[(?<headingtag>\w+)\]|(?<tag>\w+)\s+=\s+(?<code>\W+$)|(\k<tag>\w+)\s+=\s+(\k<code>.*)"
Local $sString = "[abilities]" & @CRLF & _
"UnknownDescTech0 = このアビリティの効果は不明。" & @CRLF & _
"UnknownDescFun0 = 説明なし。" & @CRLF & _
"UnknownName = ???のアビリティ。" & @CRLF & _
"" & @CRLF & _
"OneHitDeathName = ワンパンヒーローのバッジ" & @CRLF & _
"OneHitDeathDesc0 = 一発で死にます。上級者向け!" & @CRLF & _
"" & @CRLF & _
"SuckInOrbsName = 磁石のバッジ" & @CRLF & _
"SuckInOrbsFun0 = アイテムに手が届かない? これでもう安心。" & @CRLF & _
"SuckInOrbsTech0 = 自動で近くのアイテムを引き寄せます!" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"[abilities_test]" & @CRLF & _
"UnknownName = ??? Ability" & @CRLF & _
"UnknownDescFun0 = No description." & @CRLF & _
"UnknownDescTech0 = This ability does not seem to have any purpose." & @CRLF & _
"" & @CRLF & _
"OneHitDeathName = 1-Hit Hero Badge" & @CRLF & _
"OneHitDeathDesc0 = You die in one hit. Only for the brave!" & @CRLF & _
"" & @CRLF & _
"SuckInOrbsName = Item Magnet Badge" & @CRLF & _
"SuckInOrbsFun0 = Item just out of reach? No longer a problem!" & @CRLF & _
"SuckInOrbsTech0 = Automatically attract nearby collectibles!"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")