import Foundation
let pattern = #"<!--(.*?)-->|<(?P<tag>[a-z0-9]+?)[^>]*>.*?<\/(?P=tag)>|<([a-z0-9]+).*?\/>|[\S ]+"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.caseInsensitive, .dotMatchesLineSeparators])
let testString = #"""
<!--comment1
-->
<h1>header</h1>
<img src="http://example.com/img.png" title="single tag"/>
<p>long text</p>
<img src="http://example.com/img2.png"
title="single tag"/>
<!-- comment1 -->
<ul>
<li>item1</li>
<li>item2</li>
<li>item3</li>
</ul>
some text
<br class="unclosed">
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)