// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?is)<!--(.*?)-->|<(?P<tag>[a-z0-9]+?)[^>]*>.*?<\/(?P=tag)>|<([a-z0-9]+).*?\/>|[\S ]+").unwrap();
let string = "<!--comment1
-->
<h1>header</h1>
<img src=\"http://example.com/img.png\" title=\"single tag\"/>
<p>long text</p>
<img src=\"http://example.com/img2.png\"
title=\"single tag\"/>
<!-- comment1 -->
<ul>
<li>item1</li>
<li>item2</li>
<li>item3</li>
</ul>
some text
<br class=\"unclosed\">
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}