const regex = /(?(DEFINE)
(?<varchar> [[:alnum:]] | [-_] )
(?<funcname> [[:alpha:]](?&varchar)* )
(?<varname> \$(?&funcname) )
(?<typepart> [[:alpha:][[:alnum:]]*)
(?<typename> \[ (?&typepart) ( \.(?&typepart) )* \] )
(?<arg> (?&typename)? \s* (?&varname) )
(?<arglist> (?&arg) ( \s*,\s* (?&arg) )* )
(?<args> ( \( (?&arglist)? \) )? )
(?<func_decl> ^ \s* function \s+ (?&funcname) \s* (?&args) \s* \{ )
)
(?&func_decl)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?(DEFINE)
(?<varchar> [[:alnum:]] | [-_] )
(?<funcname> [[:alpha:]](?&varchar)* )
(?<varname> \\$(?&funcname) )
(?<typepart> [[:alpha:][[:alnum:]]*)
(?<typename> \\[ (?&typepart) ( \\.(?&typepart) )* \\] )
(?<arg> (?&typename)? \\s* (?&varname) )
(?<arglist> (?&arg) ( \\s*,\\s* (?&arg) )* )
(?<args> ( \\( (?&arglist)? \\) )? )
(?<func_decl> ^ \\s* function \\s+ (?&funcname) \\s* (?&args) \\s* \\{ )
)
(?&func_decl)', 'gm')
const str = `function Main (\$x, [string]\$y) {
function Get-Content {
function main_- () {
function main([string.Array] \$mfd_) { `;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);