#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?xm)(?(DEFINE) " & @CRLF & _
" (?<varchar> [[:alnum:]] | [-_] )" & @CRLF & _
" (?<funcname> [[:alpha:]](?&varchar)* )" & @CRLF & _
" (?<varname> \$(?&funcname) )" & @CRLF & _
" (?<typepart> [[:alpha:][[:alnum:]]*)" & @CRLF & _
" (?<typename> \[ (?&typepart) ( \.(?&typepart) )* \] )" & @CRLF & _
" (?<arg> (?&typename)? \s* (?&varname) ) " & @CRLF & _
" (?<arglist> (?&arg) ( \s*,\s* (?&arg) )* )" & @CRLF & _
" (?<args> ( \( (?&arglist)? \) )? )" & @CRLF & _
" (?<func_decl> ^ \s* function \s+ (?&funcname) \s* (?&args) \s* \{ )" & @CRLF & _
") " & @CRLF & _
"(?&func_decl)"
Local $sString = "function Main ($x, [string]$y) {" & @CRLF & _
" function Get-Content {" & @CRLF & _
" function main_- () { " & @CRLF & _
"function main([string.Array] $mfd_) { "
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)