re = /^(?:https?:\/\/)?(?:(?:www|gaming)\.)?youtube\.com\/(?:channel\/|(?:c\/)|(?:user\/)?)([a-z\-_0-9]+)\/?(?:[\?#]?.*)/mi
str = 'https://www.youtube.com/c/LeSanctuaireNotreDamedeLourdes/zef
https://www.youtube.com/channel/UC7zlbnNCnuAPiC3goKcFgUg/zefzf
https://www.youtube.com/user/IciJapon/zefzef
https://www.youtube.com/IciJapon
https://www.youtube.com/c/LudovicBvideos
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end