$re = '/^(?:https?:\/\/)?(?:(?:www|gaming)\.)?youtube\.com\/(?:channel\/|(?:c\/)|(?:user\/)?)([a-z\-_0-9]+)\/?(?:[\?#]?.*)/mi';
$str = 'https://www.youtube.com/c/LeSanctuaireNotreDamedeLourdes/zef
https://www.youtube.com/channel/UC7zlbnNCnuAPiC3goKcFgUg/zefzf
https://www.youtube.com/user/IciJapon/zefzef
https://www.youtube.com/IciJapon
https://www.youtube.com/c/LudovicBvideos
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);