import Foundation
let pattern = #"^(?P<str_lit>(?P<begin_quote>(?P<single_quote>')|\")(?:(?(single_quote)\"|')|\\[\"']|\\[^\r\n ]|[^\"'\\\r\n])*?(?P=begin_quote))$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
"double-quoted string"
'single-quoted string'
"unexpected EOL
'unexpected EOL
"unclosed backslash escape: \"
"properly doubled backslash: \\"
"escaped ' quotes and backslash escapes \' are \" \n allowed"
"\t\tindented code\r\n"
"invalid escape \%"
"'"
"space is not a valid backslash escape: \ "
"or newline either: \
"hopefully there aren't any edge-cases I didn't think of"
"""oh, and single-line docstrings count as three string literals, so you would have to repeat the same expression multiple times to match it"""
"""and multi-line docstrings won't match even if you repeat the expression multiple times
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)