import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?P<str_lit>(?P<begin_quote>(?P<single_quote>')|\\\")(?:(?(single_quote)\\\"|')|\\\\[\\\"']|\\\\[^\\r\\n ]|[^\\\"'\\\\\\r\\n])*?(?P=begin_quote))$";
final String string = "\"double-quoted string\"\n"
+ "'single-quoted string'\n"
+ "\"unexpected EOL\n"
+ "'unexpected EOL\n"
+ "\"unclosed backslash escape: \\\"\n"
+ "\"properly doubled backslash: \\\\\"\n"
+ "\"escaped ' quotes and backslash escapes \\' are \\\" \\n allowed\"\n"
+ "\"\\t\\tindented code\\r\\n\"\n"
+ "\"invalid escape \\%\"\n"
+ "\"'\"\n"
+ "\"space is not a valid backslash escape: \\ \"\n"
+ "\"or newline either: \\\n"
+ "\"hopefully there aren't any edge-cases I didn't think of\"\n"
+ "\"\"\"oh, and single-line docstrings count as three string literals, so you would have to repeat the same expression multiple times to match it\"\"\"\n"
+ "\"\"\"and multi-line docstrings won't match even if you repeat the expression multiple times";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}