$re = '%(?!<xref[^>]*>)(-)(?![^<]*</xref>)%';
$str = 'asdf-asdf<xref ref-type="fn-1"/>
asdf-asdf<xref ref-type="fn-1"></xref>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);