using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!<xref[^>]*>)(-)(?![^<]*</xref>)";
string input = @"asdf-asdf<xref ref-type=""fn-1""/>
asdf-asdf<xref ref-type=""fn-1""></xref>
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}