import Foundation
let pattern = #"2017-06-29\s06:50:(\d+).*?([A-Z]+).*?(?:\[(.*?[^]]+))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
2017-06-29 06:50:00,244 SEVERE [com.netcracker.platform.queueservice.queue.FailoverService] (QuartzScheduler_Worker-4) - Error while recover messages for queue [ProxyQueue]com.netcracker.framework.transactions.TxException: javax.transa
ction.RollbackException: ARJUNA016053: Could not commit transaction.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)