import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "2017-06-29\\s06:50:(\\d+).*?([A-Z]+).*?(?:\\[(.*?[^]]+))";
final String string = "2017-06-29 06:50:00,244 SEVERE [com.netcracker.platform.queueservice.queue.FailoverService] (QuartzScheduler_Worker-4) - Error while recover messages for queue [ProxyQueue]com.netcracker.framework.transactions.TxException: javax.transa\n"
+ "ction.RollbackException: ARJUNA016053: Could not commit transaction.\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}