package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:[d|e]{10})`)
var str = ` >|title| information
asdfsdfsdfsasdfsdfsdfsasdfsdfsdfs
asseefadfefeeedddeeeedddasdfsdf
asdfsdfsdfsasdfsdfsdfsasdfsdfsdfs
asseefadfefeeedddeeeedddasdfsdf
>|title| information
asseefadfefeeedddedeedddasdfsdf
asseefadfeasdfsdfsdfsasdfsdfdfsdf
asdfsdfsdfsasdfsdfsdfsasdfsdfsdfs
asseefadfefeeedddedeedddasdfsdf`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}