#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:[d|e]{10})"
Local $sString = " >|title| information" & @CRLF & _
"asdfsdfsdfsasdfsdfsdfsasdfsdfsdfs" & @CRLF & _
"asseefadfefeeedddeeeedddasdfsdf" & @CRLF & _
"asdfsdfsdfsasdfsdfsdfsasdfsdfsdfs" & @CRLF & _
"asseefadfefeeedddeeeedddasdfsdf" & @CRLF & _
">|title| information" & @CRLF & _
"asseefadfefeeedddedeedddasdfsdf" & @CRLF & _
"asseefadfeasdfsdfsdfsasdfsdfdfsdf" & @CRLF & _
"asdfsdfsdfsasdfsdfsdfsasdfsdfsdfs" & @CRLF & _
"asseefadfefeeedddedeedddasdfsdf"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")